What’s Vulnerable › Vulnerabilities
CVE-2014-5220
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-08 · updated 2026-06-17
- Weakness: CWE-77
Description
The mdcheck script of the mdadm package for openSUSE 13.2 prior to version 3.3.1-5.14.1 does not properly sanitize device names, which allows local attackers to execute arbitrary commands as root.
Affected products
- Mdadm Project Mdadm: before 3.3.3 — fixed in 3.3.3
- Opensuse: 13.2
How to fix
Upgrade to a fixed version: Mdadm Project Mdadm 3.3.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=910500
- https://lists.opensuse.org/opensuse-updates/2015-02/msg00069.html
- https://bugzilla.suse.com/show_bug.cgi?id=910500
- https://lists.opensuse.org/opensuse-updates/2015-02/msg00069.html
Get alerted when CVE-2014-5220 or the next vulnerability affects your stack