What’s Vulnerable › Vulnerabilities
CVE-2014-5278
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-07 · updated 2026-06-17
Description
A vulnerability exists in Docker before 1.2 via container names, which may collide with and override container IDs.
Affected products
- Docker Engine: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Docker Engine 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/xxg1413/docker-security/tree/master/CVE-2014-5278
- https://groups.google.com/forum/#%21topic/docker-announce/lK6fQY6Jy84
- https://groups.google.com/forum/message/raw?msg=docker-user/jyf9_mYcMI8/EIZfwe2QNzYJ
- https://github.com/xxg1413/docker-security/tree/master/CVE-2014-5278
- https://groups.google.com/forum/#%21topic/docker-announce/lK6fQY6Jy84
- https://groups.google.com/forum/message/raw?msg=docker-user/jyf9_mYcMI8/EIZfwe2QNzYJ
Get alerted when CVE-2014-5278 or the next vulnerability affects your stack