What’s Vulnerable › Vulnerabilities
CVE-2014-5282
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-06 · updated 2026-06-17
- Weakness: CWE-20
Description
Docker before 1.3 does not properly validate image IDs, which allows remote attackers to redirect to another image through the loading of untrusted images via 'docker load'.
Affected products
- Docker Engine: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: Docker Engine 1.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1168436
- https://groups.google.com/forum/#%21msg/docker-announce/aQoVmQlcE0A/smPuBNYf8VwJ
- https://bugzilla.redhat.com/show_bug.cgi?id=1168436
- https://groups.google.com/forum/#%21msg/docker-announce/aQoVmQlcE0A/smPuBNYf8VwJ
Get alerted when CVE-2014-5282 or the next vulnerability affects your stack