What’s Vulnerable › Vulnerabilities
CVE-2014-5353
- Severity: low (CVSS 3.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-12-16 · updated 2026-06-17
- Weakness: CWE-476
Description
The krb5_ldap_get_password_policy_from_dn function in plugins/kdb/ldap/libkdb_ldap/ldap_pwd_policy.c in MIT Kerberos 5 (aka krb5) before 1.13.1, when the KDC uses LDAP, allows remote authenticated users to cause a denial of service (daemon crash) via a successful LDAP query with no results, as demonstrated by using an incorrect object type for a password policy.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 14.04, 14.10
- Debian Linux: 7.0
- Fedoraproject Fedora: 22
- MIT Kerberos 5: before 1.13.1 — fixed in 1.13.1
- Opensuse: 13.1, 13.2
- Oracle Corporation Solaris Operating System: 10, 11.2
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 6.6, 7.3, 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 6.6, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 6.6, 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.13.1. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0536.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155828.html
- http://lists.opensuse.org/opensuse-updates/2015-03/msg00061.html
- http://rhn.redhat.com/errata/RHSA-2015-0439.html
- http://rhn.redhat.com/errata/RHSA-2015-0794.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:009
- http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
- http://www.securityfocus.com/bid/71679
- http://www.securitytracker.com/id/1031376
- http://www.ubuntu.com/usn/USN-2498-1
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773226
- https://github.com/krb5/krb5/commit/d1f707024f1d0af6e54a18885322d70fa15ec4d3
Get alerted when CVE-2014-5353 or the next vulnerability affects your stack