What’s Vulnerable › Vulnerabilities

CVE-2014-6271: GNU Bourne-Again Shell (Bash) Arbitrary Code Execution Vulnerability

Description

GNU Bash through 4.3 processes trailing strings after function definitions in the values of environment variables, which allows remote attackers to execute arbitrary code via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution, aka "ShellShock." NOTE: the original fix for this issue was incorrect; CVE-2014-7169 has been assigned to cover the vulnerability that is still present after the incorrect fix.

Affected products

How to fix

Upgrade to a fixed version: macOS 10.10.0; Arista Networks EOS 4.9.12, 4.10.9, 4.11.11, 4.12.9; Check Point Security Gateway r77.30; Citrix Netscaler Sdx Firmware 9.3.67.5r1, 10.1.129.11r1, 10.5.52.11r1; IBM Flex System V7000 Firmware 7.1.0.11, 7.2.0.9, 7.3.0.7; IBM San Volume Controller Firmware 7.1.0.11, 7.2.0.9, 7.3.0.7; IBM Software Defined Network For Virtual Environments 1.2.1; IBM Stn6500 Firmware 3.8.0.07, 3.9.1.08, 4.1.2.06; IBM Stn6800 Firmware 3.8.0.07, 3.9.1.08, 4.1.2.06; IBM Stn7800 Firmware 3.8.0.07, 3.9.1.08, 4.1.2.06; IBM Storwize V3500 Firmware 7.1.0.11, 7.2.0.9, 7.3.0.7; IBM Storwize V3700 Firmware 7.1.0.11, 7.2.0.9, 7.3.0.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-6271 or the next vulnerability affects your stack