What’s Vulnerable › Vulnerabilities
CVE-2014-6412
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-12 · updated 2026-06-17
- Weakness: CWE-640
Description
WordPress before 4.4 makes it easier for remote attackers to predict password-recovery tokens via a brute-force approach.
Affected products
- WordPress: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: WordPress 4.4.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/130380/WordPress-Failed-Randomness.html
- http://seclists.org/fulldisclosure/2015/Feb/42
- http://seclists.org/fulldisclosure/2015/Feb/53
- http://www.securityfocus.com/bid/72589
- http://www.securitytracker.com/id/1031749
- https://bugzilla.redhat.com/show_bug.cgi?id=1192474
- https://core.trac.wordpress.org/ticket/28633
- http://packetstormsecurity.com/files/130380/WordPress-Failed-Randomness.html
- http://seclists.org/fulldisclosure/2015/Feb/42
- http://seclists.org/fulldisclosure/2015/Feb/53
- http://www.securityfocus.com/bid/72589
- http://www.securitytracker.com/id/1031749
Get alerted when CVE-2014-6412 or the next vulnerability affects your stack