What’s Vulnerable › Vulnerabilities
CVE-2014-6464
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-10-15 · updated 2026-06-17
Description
Unspecified vulnerability in Oracle MySQL Server 5.5.39 and earlier and 5.6.20 and earlier allows remote authenticated users to affect availability via vectors related to SERVER:INNODB DML FOREIGN KEYS.
Affected products
- MariaDB: from 5.5.0 before 5.5.40; from 10.0.0 before 10.0.15 — fixed in 10.0.15, 5.5.40
- MySQL Server: from 5.5.0 through 5.5.39; from 5.6.0 through 5.6.20
- SUSE Linux Enterprise Server 15 SP1: 12
- SUSE Linux Enterprise Server: 12
- SUSE Linux Enterprise Software Development Kit: 12
- SUSE Linux Enterprise Workstation Extension: 12
How to fix
Upgrade to a fixed version: MariaDB 10.0.15, 5.5.40. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00016.html
- http://secunia.com/advisories/61579
- http://secunia.com/advisories/62073
- http://security.gentoo.org/glsa/glsa-201411-02.xml
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html
- http://www.oracle.com/technetwork/topics/security/cpuoct2014-1972960.html
- http://www.securityfocus.com/bid/70451
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00016.html
- http://secunia.com/advisories/61579
- http://secunia.com/advisories/62073
- http://security.gentoo.org/glsa/glsa-201411-02.xml
Get alerted when CVE-2014-6464 or the next vulnerability affects your stack