What’s Vulnerable › Vulnerabilities
CVE-2014-6604
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in class-s2-list-table.php in the Subscribe2 plugin before 10.16 for WordPress allows remote attackers to inject arbitrary web script or HTML via the ip parameter.
Affected products
- wedevs Subscribe2 – Form, Email Subscribers & Newsletters: before 10.16 — fixed in 10.16
How to fix
Upgrade to a fixed version: wedevs Subscribe2 – Form, Email Subscribers & Newsletters 10.16. Check the vendor advisory for mitigations.
References
- http://barmat.io/blog/2014/10/01/stored-xss-vulnerability-in-the-wordpress-plugin-subscribe2/
- https://plugins.trac.wordpress.org/changeset/993564/subscribe2
- http://barmat.io/blog/2014/10/01/stored-xss-vulnerability-in-the-wordpress-plugin-subscribe2/
- https://plugins.trac.wordpress.org/changeset/993564/subscribe2
Get alerted when CVE-2014-6604 or the next vulnerability affects your stack