What’s Vulnerable › Vulnerabilities
CVE-2014-7205
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 78.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-10-08 · updated 2026-06-17
- Weakness: CWE-94
Description
Eval injection vulnerability in the internals.batch function in lib/batch.js in the bassmaster plugin before 1.5.2 for the hapi server framework for Node.js allows remote attackers to execute arbitrary Javascript code via unspecified vectors.
Affected products
- Bassmaster Project Bassmaster: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Bassmaster Project Bassmaster 1.5.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/09/30/10
- http://www.securityfocus.com/bid/70180
- https://exchange.xforce.ibmcloud.com/vulnerabilities/96730
- https://github.com/hapijs/bassmaster/commit/b751602d8cb7194ee62a61e085069679525138c4
- https://nodesecurity.io/advisories/bassmaster_js_injection
- https://www.exploit-db.com/exploits/40689/
- http://www.openwall.com/lists/oss-security/2014/09/30/10
- http://www.securityfocus.com/bid/70180
- https://exchange.xforce.ibmcloud.com/vulnerabilities/96730
- https://github.com/hapijs/bassmaster/commit/b751602d8cb7194ee62a61e085069679525138c4
- https://nodesecurity.io/advisories/bassmaster_js_injection
- https://www.exploit-db.com/exploits/40689/
Get alerted when CVE-2014-7205 or the next vulnerability affects your stack