What’s Vulnerable › Vulnerabilities
CVE-2014-7210
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-276
Description
pdns specific as packaged in Debian in version before 3.3.1-1 creates a too privileged MySQL user. It was discovered that the maintainer scripts of pdns-backend-mysql grant too wide database permissions for the pdns user. Other backends are not affected.
Affected products
- Debian Linux: 7.0
- Debian pdns: before 3.3.1-1 — fixed in 3.3.1-1
How to fix
Upgrade to a fixed version: Debian pdns 3.3.1-1. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2016/05/msg00046.html
- https://salsa.debian.org/debian/pdns/-/commit/f0de6b3583039bb63344fbd5eb246939264d7b05
Get alerted when CVE-2014-7210 or the next vulnerability affects your stack