What’s Vulnerable › Vulnerabilities
CVE-2014-7808
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-09-15 · updated 2026-06-17
- Weakness: CWE-310
Description
Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.
Affected products
- Apache Software Foundation Apache Wicket: from 1.5.0 before 1.5.13; from 6.0.0 before 6.19.0; 7.0.0-milestone1, 7.0.0-milestone2, 7.0.0-milestone3, 7.0.0-milestone4, 7.0.0-milestone5 — fixed in 1.5.13, 6.19.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Wicket 1.5.13, 6.19.0. Check the vendor advisory for mitigations.
References
- http://mail-archives.apache.org/mod_mbox/wicket-users/201502.mbox/%3CCAMomwMpLPDYezc=iFofm1R1Uq37vUFJ8VC-_ex5SU8-HAKBoRw%40mail.gmail.com%3E
- https://www.smrrd.de/cve-2014-7808-apache-wicket-csrf-2014.html
- http://mail-archives.apache.org/mod_mbox/wicket-users/201502.mbox/%3CCAMomwMpLPDYezc=iFofm1R1Uq37vUFJ8VC-_ex5SU8-HAKBoRw%40mail.gmail.com%3E
- https://www.smrrd.de/cve-2014-7808-apache-wicket-csrf-2014.html
Get alerted when CVE-2014-7808 or the next vulnerability affects your stack