What’s Vulnerable › Vulnerabilities
CVE-2014-8089
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-17 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.
Affected products
- Fedoraproject Fedora: 19, 20, 21
- Red Hat Enterprise Linux: 6.0, 7.0
- Zend Technologies Zend Framework: before 1.12.9; from 2.2.0 before 2.2.8; from 2.3.0 before 2.3.3 — fixed in 1.12.9, 2.2.8, 2.3.3
How to fix
Upgrade to a fixed version: Zend Technologies Zend Framework 1.12.9, 2.2.8, 2.3.3. Check the vendor advisory for mitigations.
References
- http://framework.zend.com/security/advisory/ZF2014-06
- http://seclists.org/oss-sec/2014/q4/276
- http://www.securityfocus.com/bid/70011
- https://bugzilla.redhat.com/show_bug.cgi?id=1151277
- http://framework.zend.com/security/advisory/ZF2014-06
- http://seclists.org/oss-sec/2014/q4/276
- http://www.securityfocus.com/bid/70011
- https://bugzilla.redhat.com/show_bug.cgi?id=1151277
Get alerted when CVE-2014-8089 or the next vulnerability affects your stack