What’s Vulnerable › Vulnerabilities
CVE-2014-8109
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-12-29 · updated 2026-06-17
- Weakness: CWE-863
Description
mod_lua.c in the mod_lua module in the Apache HTTP Server 2.3.x and 2.4.x through 2.4.10 does not support an httpd configuration in which the same Lua authorization provider is used with different arguments within different contexts, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging multiple Require directives, as demonstrated by a configuration that specifies authorization for one group to access a certain directory, and authorization for a second group to access a second directory.
Affected products
- Apache HTTP Server: 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.6, 2.4.7 (+2)
- Canonical Ubuntu Linux: 10.04, 12.04, 14.04, 14.10
- Fedoraproject Fedora: 21
- Oracle Corporation Enterprise Manager Ops Center: before 12.1.4; 12.2.0, 12.2.1, 12.3.0 — fixed in 12.1.4
How to fix
Upgrade to a fixed version: Oracle Corporation Enterprise Manager Ops Center 12.1.4. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2015-0011.html
- http://lists.apple.com/archives/security-announce/2015/Aug/msg00001.html
- http://lists.apple.com/archives/security-announce/2015/Sep/msg00004.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-June/159352.html
- http://www.openwall.com/lists/oss-security/2014/11/28/5
- http://www.oracle.com/technetwork/topics/security/cpujan2016-2367955.html
- http://www.securityfocus.com/bid/73040
- http://www.ubuntu.com/usn/USN-2523-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1174077
- https://github.com/apache/httpd/commit/3f1693d558d0758f829c8b53993f1749ddf6ffcb
- https://issues.apache.org/bugzilla/show_bug.cgi?id=57204
- https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e80293cde02fcd65286ba%40%3Ccvs.httpd.apache.org%3E
Get alerted when CVE-2014-8109 or the next vulnerability affects your stack