What’s Vulnerable › Vulnerabilities
CVE-2014-8159
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-03-16 · updated 2026-06-17
- Weakness: CWE-264
Description
The InfiniBand (IB) implementation in the Linux kernel package before 2.6.32-504.12.2 on Red Hat Enterprise Linux (RHEL) 6 does not properly restrict use of User Verbs for registration of memory regions, which allows local users to access arbitrary physical memory locations, and consequently cause a denial of service (system crash) or gain privileges, by leveraging permissions on a uverbs device under /dev/infiniband/.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 14.04, 14.10
- Debian Linux: 7.0, 8.0
- Linux kernel: from 2.6.12 before 3.2.69; from 3.3 before 3.4.108; from 3.5 before 3.10.75; from 3.11 before 3.12.41; from 3.13 before 3.14.39; from 3.15 before 3.16.35 — fixed in 3.10.75, 3.12.41, 3.14.39, 3.16.35, 3.18.13, 3.19.5
How to fix
Upgrade to a fixed version: Linux kernel 3.10.75, 3.12.41, 3.14.39, 3.16.35. Check the vendor advisory for mitigations.
References
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10705
- http://lists.fedoraproject.org/pipermail/package-announce/2015-March/152747.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00011.html
- http://rhn.redhat.com/errata/RHSA-2015-0674.html
- http://rhn.redhat.com/errata/RHSA-2015-0695.html
- http://rhn.redhat.com/errata/RHSA-2015-0726.html
- http://rhn.redhat.com/errata/RHSA-2015-0751.html
- http://rhn.redhat.com/errata/RHSA-2015-0782.html
Get alerted when CVE-2014-8159 or the next vulnerability affects your stack