What’s Vulnerable › Vulnerabilities
CVE-2014-8160
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-03-02 · updated 2026-06-17
- Weakness: CWE-20
Description
net/netfilter/nf_conntrack_proto_generic.c in the Linux kernel before 3.18 generates incorrect conntrack entries during handling of certain iptables rule sets for the SCTP, DCCP, GRE, and UDP-Lite protocols, which allows remote attackers to bypass intended access restrictions via packets with disallowed port numbers.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10
- Debian Linux: 7.0, 8.0
- Linux kernel: before 3.18 — fixed in 3.18
- Opensuse: 13.1
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 6.5, 6.6, 7.3, 7.6
- RedHat Enterprise Linux Server Eus: 6.5, 6.6, 7.3, 7.4, 7.5, 7.6 (+1)
- RedHat Enterprise Linux Server Tus: 6.5, 6.6, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- SUSE Linux Enterprise Server 15 SP1: 12
- SUSE Linux Enterprise Real Time Extension: 11-sp3
- SUSE Linux Enterprise Server: 11-sp1, 12
- SUSE Linux Enterprise Software Development Kit: 12
- SUSE Linux Enterprise Workstation Extension: 12
How to fix
Upgrade to a fixed version: Linux kernel 3.18. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=db29a9508a9246e77087c5531e45b2c88ec6988b
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00020.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00015.html
- http://rhn.redhat.com/errata/RHSA-2015-0284.html
- http://rhn.redhat.com/errata/RHSA-2015-0290.html
- http://rhn.redhat.com/errata/RHSA-2015-0674.html
- http://www.debian.org/security/2015/dsa-3170
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:057
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:058
- http://www.openwall.com/lists/oss-security/2015/01/14/3
Get alerted when CVE-2014-8160 or the next vulnerability affects your stack