What’s Vulnerable › Vulnerabilities

CVE-2014-8161

Description

PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allows remote authenticated users to obtain sensitive column values by triggering constraint violation and then reading the error message.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 9.0.19, 9.1.15, 9.2.10, 9.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-8161 or the next vulnerability affects your stack