What’s Vulnerable › Vulnerabilities
CVE-2014-8178
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-17 · updated 2026-06-17
- Weakness: CWE-20
Description
Docker Engine before 1.8.3 and CS Docker Engine before 1.6.2-CS7 do not use a globally unique identifier to store image layers, which makes it easier for attackers to poison the image cache via a crafted image in pull or push commands.
Affected products
- Docker Cs Engine: before 1.6.2-cs7 — fixed in 1.6.2-cs7
- Docker Engine: before 1.8.3 — fixed in 1.8.3
- Opensuse: 13.2
How to fix
Upgrade to a fixed version: Docker Cs Engine 1.6.2-cs7; Docker Engine 1.8.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00014.html
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00036.html
- https://github.com/docker/docker/blob/master/CHANGELOG.md#183-2015-10-12
- https://groups.google.com/forum/#%21msg/docker-dev/bWVVtLNbFy8/UaefOqMOCAAJ
- https://www.docker.com/legal/docker-cve-database
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00014.html
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00036.html
- https://github.com/docker/docker/blob/master/CHANGELOG.md#183-2015-10-12
- https://groups.google.com/forum/#%21msg/docker-dev/bWVVtLNbFy8/UaefOqMOCAAJ
- https://www.docker.com/legal/docker-cve-database
Get alerted when CVE-2014-8178 or the next vulnerability affects your stack