What’s Vulnerable › Vulnerabilities
CVE-2014-8184
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-02 · updated 2026-06-17
- Weakness: CWE-121
Description
A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.
Affected products
- liblouis: from 2.5.0 before 2.5.4 — fixed in 2.5.4
How to fix
Upgrade to a fixed version: liblouis 2.5.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-8184
- https://github.com/liblouis/liblouis/issues/425
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-8184
- https://github.com/liblouis/liblouis/issues/425
Get alerted when CVE-2014-8184 or the next vulnerability affects your stack