What’s Vulnerable › Vulnerabilities
CVE-2014-8412
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-11-24 · updated 2026-06-17
- Weakness: CWE-264
Description
The (1) VoIP channel drivers, (2) DUNDi, and (3) Asterisk Manager Interface (AMI) in Asterisk Open Source 1.8.x before 1.8.32.1, 11.x before 11.14.1, 12.x before 12.7.1, and 13.x before 13.0.1 and Certified Asterisk 1.8.28 before 1.8.28-cert3 and 11.6 before 11.6-cert8 allows remote attackers to bypass the ACL restrictions via a packet with a source IP that does not share the address family as the first ACL entry.
Affected products
- Digium Asterisk: from 1.8.0 before 1.8.32.1; from 11.0.0 before 11.14.1; from 12.0.0 before 12.7.1; from 13.0.0 before 13.0.1 — fixed in 1.8.32.1, 11.14.1, 12.7.1, 13.0.1
- Digium Certified Asterisk: 1.8.28-cert1, 1.8.28-cert2, 1.8.28.0, 11.6-cert1, 11.6-cert2, 11.6-cert3 (+5)
How to fix
Upgrade to a fixed version: Digium Asterisk 1.8.32.1, 11.14.1, 12.7.1, 13.0.1. Check the vendor advisory for mitigations.
References
- http://downloads.asterisk.org/pub/security/AST-2014-012.html
- http://downloads.asterisk.org/pub/security/AST-2014-012.html
Get alerted when CVE-2014-8412 or the next vulnerability affects your stack