What’s Vulnerable › Vulnerabilities
CVE-2014-8415
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-11-24 · updated 2026-06-17
- Weakness: CWE-20
Description
Race condition in the chan_pjsip channel driver in Asterisk Open Source 12.x before 12.7.1 and 13.x before 13.0.1 allows remote attackers to cause a denial of service (assertion failure and crash) via a cancel request for a SIP session with a queued action to (1) answer a session or (2) send ringing.
Affected products
- Digium Asterisk: from 12.0.0 before 12.7.1; from 13.0.0 before 13.0.1 — fixed in 12.7.1, 13.0.1
How to fix
Upgrade to a fixed version: Digium Asterisk 12.7.1, 13.0.1. Check the vendor advisory for mitigations.
References
- http://downloads.asterisk.org/pub/security/AST-2014-015.html
- http://downloads.asterisk.org/pub/security/AST-2014-015.html
Get alerted when CVE-2014-8415 or the next vulnerability affects your stack