What’s Vulnerable › Vulnerabilities
CVE-2014-8417
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-11-24 · updated 2026-06-17
- Weakness: CWE-264
Description
ConfBridge in Asterisk 11.x before 11.14.1, 12.x before 12.7.1, and 13.x before 13.0.1 and Certified Asterisk 11.6 before 11.6-cert8 allows remote authenticated users to (1) gain privileges via vectors related to an external protocol to the CONFBRIDGE dialplan function or (2) execute arbitrary system commands via a crafted ConfbridgeStartRecord AMI action.
Affected products
- Digium Asterisk: from 11.0.0 before 11.14.1; from 12.0.0 before 12.7.1; from 13.0.0 before 13.0.1 — fixed in 11.14.1, 12.7.1, 13.0.1
- Digium Certified Asterisk: 11.6-cert1, 11.6-cert2, 11.6-cert3, 11.6-cert4, 11.6-cert5, 11.6-cert6 (+2)
How to fix
Upgrade to a fixed version: Digium Asterisk 11.14.1, 12.7.1, 13.0.1. Check the vendor advisory for mitigations.
References
- http://downloads.asterisk.org/pub/security/AST-2014-017.html
- http://downloads.asterisk.org/pub/security/AST-2014-017.html
Get alerted when CVE-2014-8417 or the next vulnerability affects your stack