What’s Vulnerable › Vulnerabilities
CVE-2014-8418
- Severity: critical (CVSS 9.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-11-24 · updated 2026-06-17
- Weakness: CWE-264
Description
The DB dialplan function in Asterisk Open Source 1.8.x before 1.8.32, 11.x before 11.1.4.1, 12.x before 12.7.1, and 13.x before 13.0.1 and Certified Asterisk 1.8 before 1.8.28-cert8 and 11.6 before 11.6-cert8 allows remote authenticated users to gain privileges via a call from an external protocol, as demonstrated by the AMI protocol.
Affected products
- Digium Asterisk: from 1.8.0 through 1.8.32.0; from 11.0.0 before 11.14.1; from 12.0.0 before 12.7.1 — fixed in 11.14.1, 12.7.1
- Digium Certified Asterisk: 1.8.28, 1.8.28-cert1, 1.8.28-cert1-rc1, 1.8.28-cert2, 1.8.28-cert3, 1.8.28-cert4 (+9)
How to fix
Upgrade to a fixed version: Digium Asterisk 11.14.1, 12.7.1. Check the vendor advisory for mitigations.
References
- http://downloads.asterisk.org/pub/security/AST-2014-018.html
- http://downloads.asterisk.org/pub/security/AST-2014-018.html
Get alerted when CVE-2014-8418 or the next vulnerability affects your stack