What’s Vulnerable › Vulnerabilities
CVE-2014-8439: Adobe Flash Player Dereferenced Pointer Vulnerability
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: yes — in CISA KEV since 2022-05-25
- EPSS: 20.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-11-25 · updated 2026-06-17
- Weakness: CWE-119
Description
Adobe Flash Player before 13.0.0.258 and 14.x and 15.x before 15.0.0.239 on Windows and OS X and before 11.2.202.424 on Linux, Adobe AIR before 15.0.0.293, Adobe AIR SDK before 15.0.0.302, and Adobe AIR SDK & Compiler before 15.0.0.302 allow attackers to execute arbitrary code or cause a denial of service (invalid pointer dereference) via unspecified vectors.
Affected products
- Adobe Air: through 15.0.0.292
- Adobe Air Sdk: through 15.0.0.301
- Adobe Air Sdk & Compiler: before 15.0.0.302 — fixed in 15.0.0.302
- Adobe Flash Player 24.0.0.186 and earlier.: through 11.2.202.418; through 15.0.0.223; through 13.0.0.252
How to fix
Upgrade to a fixed version: Adobe Air Sdk & Compiler 15.0.0.302. Check the vendor advisory for mitigations.
References
- http://helpx.adobe.com/security/products/flash-player/apsb14-22.html
- http://helpx.adobe.com/security/products/flash-player/apsb14-26.html
- http://lists.opensuse.org/opensuse-security-announce/2014-11/msg00020.html
- http://lists.opensuse.org/opensuse-security-announce/2014-12/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2014-12/msg00004.html
- http://rhn.redhat.com/errata/RHSA-2014-1915.html
- http://secunia.com/advisories/60217
- http://www.securityfocus.com/bid/71289
- http://www.securitytracker.com/id/1031259
- https://exchange.xforce.ibmcloud.com/vulnerabilities/98932
- https://www.f-secure.com/weblog/archives/00002768.html
- http://helpx.adobe.com/security/products/flash-player/apsb14-22.html
Get alerted when CVE-2014-8439 or the next vulnerability affects your stack