What’s Vulnerable › Vulnerabilities
CVE-2014-8540
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-05 · updated 2026-06-17
- Weakness: CWE-264
Description
The groups API in GitLab 6.x and 7.x before 7.4.3 allows remote authenticated guest users to modify ownership of arbitrary groups by leveraging improper permission checks.
Affected products
- GitLab: from 6.0.0 through 6.9.2; from 7.0.0 before 7.4.3 — fixed in 7.4.3
How to fix
Upgrade to a fixed version: GitLab 7.4.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/10/31/2
- http://www.securityfocus.com/bid/70841
- https://about.gitlab.com/2014/10/30/gitlab-7-4-3-released/
- https://exchange.xforce.ibmcloud.com/vulnerabilities/98449
- https://gitlab.com/gitlab-org/gitlab-ce/commit/a2dfff418bf2532ebb5aee88414107929b17eefd
- http://www.openwall.com/lists/oss-security/2014/10/31/2
- http://www.securityfocus.com/bid/70841
- https://about.gitlab.com/2014/10/30/gitlab-7-4-3-released/
- https://exchange.xforce.ibmcloud.com/vulnerabilities/98449
- https://gitlab.com/gitlab-org/gitlab-ce/commit/a2dfff418bf2532ebb5aee88414107929b17eefd
Get alerted when CVE-2014-8540 or the next vulnerability affects your stack