What’s Vulnerable › Vulnerabilities
CVE-2014-8628
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-08-24 · updated 2026-06-17
- Weakness: CWE-399
Description
Memory leak in PolarSSL before 1.2.12 and 1.3.x before 1.3.9 allows remote attackers to cause a denial of service (memory consumption) via a large number of crafted X.509 certificates. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2014-9744 for the ClientHello message issue.
Affected products
- PolarSSL: through 1.2.11; 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5 (+3)
References
- http://lists.opensuse.org/opensuse-updates/2014-11/msg00079.html
- http://www.debian.org/security/2014/dsa-3116
- https://polarssl.org/tech-updates/releases/polarssl-1.2.12-released
- https://polarssl.org/tech-updates/releases/polarssl-1.3.9-released
- http://lists.opensuse.org/opensuse-updates/2014-11/msg00079.html
- http://www.debian.org/security/2014/dsa-3116
- https://polarssl.org/tech-updates/releases/polarssl-1.2.12-released
- https://polarssl.org/tech-updates/releases/polarssl-1.3.9-released
Get alerted when CVE-2014-8628 or the next vulnerability affects your stack