What’s Vulnerable › Vulnerabilities
CVE-2014-8801
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-11-28 · updated 2026-06-17
- Weakness: CWE-22
Description
Directory traversal vulnerability in services/getfile.php in the Paid Memberships Pro plugin before 1.7.15 for WordPress allows remote attackers to read arbitrary files via a .. (dot dot) in the QUERY_STRING in a getfile action to wp-admin/admin-ajax.php.
Affected products
- Paid Memberships Pro: before 1.7.15 — fixed in 1.7.15
How to fix
Upgrade to a fixed version: Paid Memberships Pro 1.7.15. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/129189/Paid-Memberships-Pro-1.7.14.2-Path-Traversal.html
- http://security.szurek.pl/paid-memberships-pro-17142-path-traversal.html
- http://www.exploit-db.com/exploits/35303
- http://www.paidmembershipspro.com/2014/11/critical-security-update-pmpro-v1-7-15/
- http://www.securityfocus.com/bid/71293
- https://exchange.xforce.ibmcloud.com/vulnerabilities/98805
- https://wordpress.org/plugins/paid-memberships-pro/changelog/
- http://packetstormsecurity.com/files/129189/Paid-Memberships-Pro-1.7.14.2-Path-Traversal.html
- http://security.szurek.pl/paid-memberships-pro-17142-path-traversal.html
- http://www.exploit-db.com/exploits/35303
- http://www.paidmembershipspro.com/2014/11/critical-security-update-pmpro-v1-7-15/
- http://www.securityfocus.com/bid/71293
Get alerted when CVE-2014-8801 or the next vulnerability affects your stack