What’s Vulnerable › Vulnerabilities
CVE-2014-8964
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-12-16 · updated 2026-06-17
- Weakness: CWE-119
Description
Heap-based buffer overflow in PCRE 8.36 and earlier allows remote attackers to cause a denial of service (crash) or have other unspecified impact via a crafted regular expression, related to an assertion that allows zero repeats.
Affected products
- Fedoraproject Fedora: 19, 20, 21
- MariaDB: from 10.0.0 before 10.0.18 — fixed in 10.0.18
- Opensuse: 13.1, 13.2
- Oracle Corporation Solaris Operating System: 11.2
- Pcre: through 8.36
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.3, 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: MariaDB 10.0.18. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0534.html
- http://bugs.exim.org/show_bug.cgi?id=1546
- http://lists.fedoraproject.org/pipermail/package-announce/2014-December/145843.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/147474.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/147511.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/147516.html
- http://lists.opensuse.org/opensuse-updates/2015-05/msg00014.html
- http://rhn.redhat.com/errata/RHSA-2015-0330.html
- http://www.exim.org/viewvc/pcre?view=revision&revision=1513
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:002
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:137
- http://www.openwall.com/lists/oss-security/2014/11/21/6
Get alerted when CVE-2014-8964 or the next vulnerability affects your stack