What’s Vulnerable › Vulnerabilities
CVE-2014-9016
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 82.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-11-24 · updated 2026-06-17
Description
The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass) module 6.x-2.x before 6.x-2.1 for Drupal allows remote attackers to cause a denial of service (CPU and memory consumption) via a crafted request.
Affected products
- Debian Linux: 7.0
- Drupal: from 7.0 before 7.34 — fixed in 7.34
- Secure Password Hashes Project Secure Passwords Hashes: from 6.x-2.0 before 6.x-2.1 — fixed in 6.x-2.1
How to fix
Upgrade to a fixed version: Drupal 7.34; Secure Password Hashes Project Secure Passwords Hashes 6.x-2.1. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/59164
- http://secunia.com/advisories/59814
- http://www.debian.org/security/2014/dsa-3075
- http://www.openwall.com/lists/oss-security/2014/11/20/21
- http://www.openwall.com/lists/oss-security/2014/11/20/3
- http://www.openwall.com/lists/oss-security/2014/11/21/1
- https://www.drupal.org/SA-CORE-2014-006
- https://www.drupal.org/node/2378367
- https://www.drupal.org/node/2378375
- http://secunia.com/advisories/59164
- http://secunia.com/advisories/59814
- http://www.debian.org/security/2014/dsa-3075
Get alerted when CVE-2014-9016 or the next vulnerability affects your stack