What’s Vulnerable › Vulnerabilities
CVE-2014-9087
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-12-01 · updated 2026-06-17
- Weakness: CWE-191
Description
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10
- Debian Linux: 7.0, 8.0
- GnuPG: 2.1.0, 2.1.0-beta1
- GnuPG Libksba: before 1.3.2 — fixed in 1.3.2
- Mageia: 3.0, 4.0
How to fix
Upgrade to a fixed version: GnuPG Libksba 1.3.2. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0498.html
- http://lists.gnupg.org/pipermail/gnupg-announce/2014q4/000359.html
- http://secunia.com/advisories/60073
- http://secunia.com/advisories/60189
- http://secunia.com/advisories/60233
- http://www.debian.org/security/2014/dsa-3078
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:234
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:151
- http://www.securityfocus.com/bid/71285
- http://www.ubuntu.com/usn/USN-2427-1
- https://blog.fuzzing-project.org/2-Buffer-overflow-and-other-minor-issues-in-GnuPG-and-libksba-TFPA-0012014.html
- http://advisories.mageia.org/MGASA-2014-0498.html
Get alerted when CVE-2014-9087 or the next vulnerability affects your stack