What’s Vulnerable › Vulnerabilities
CVE-2014-9157
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-12-03 · updated 2026-06-17
- Weakness: CWE-134
Description
Format string vulnerability in the yyerror function in lib/cgraph/scan.l in Graphviz allows remote attackers to have unspecified impact via format string specifiers in unknown vectors, which are not properly handled in an error string.
Affected products
- Debian Linux: 7.0, 8.0
- Graphviz: before 2.42.4 — fixed in 2.42.4
How to fix
Upgrade to a fixed version: Graphviz 2.42.4. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0520.html
- http://seclists.org/oss-sec/2014/q4/784
- http://seclists.org/oss-sec/2014/q4/872
- http://secunia.com/advisories/60166
- http://www.debian.org/security/2014/dsa-3098
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:248
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:187
- http://www.securityfocus.com/bid/71283
- https://exchange.xforce.ibmcloud.com/vulnerabilities/98949
- https://github.com/ellson/graphviz/commit/99eda421f7ddc27b14e4ac1d2126e5fe41719081
- http://advisories.mageia.org/MGASA-2014-0520.html
- http://seclists.org/oss-sec/2014/q4/784
Get alerted when CVE-2014-9157 or the next vulnerability affects your stack