What’s Vulnerable › Vulnerabilities
CVE-2014-9187
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-25 · updated 2026-06-17
- Weakness: CWE-122
Description
Multiple heap-based buffer overflow vulnerabilities exist in Honeywell Experion PKS all versions prior to R400.6, all versions prior to R410.6, and all versions prior to R430.2 modules, which could lead to possible remote code execution or denial of service. Honeywell strongly encourages and recommends all customers running unsupported versions of EKPS prior to R400 to upgrade to a supported version.
Affected products
- Honeywell Experion PKS: from r400 before r400.6; from r410 before r410.6; from r430 before r430.2 — fixed in r400.6, r410.6, r430.2
How to fix
Upgrade to a fixed version: Honeywell Experion PKS r400.6, r410.6, r430.2. Check the vendor advisory for mitigations.
References
- https://ics-cert.us-cert.gov/advisories/ICSA-14-352-01
- https://ics-cert.us-cert.gov/advisories/ICSA-14-352-01
Get alerted when CVE-2014-9187 or the next vulnerability affects your stack