What’s Vulnerable › Vulnerabilities
CVE-2014-9323
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-12-16 · updated 2026-10-14
- Weakness: CWE-476
Description
The xdr_status_vector function in Firebird before 2.1.7 and 2.5.x before 2.5.3 SU1 allows remote attackers to cause a denial of service (NULL pointer dereference, segmentation fault, and crash) via an op_response action with a non-empty status.
Affected products
- Canonical Ubuntu Linux: 14.04
- Debian Linux: 7.0, 8.0
- FirebirdSQL firebird: before 2.1.7; from 2.5 through 2.5.3 — fixed in 2.1.7
- openSUSE Evergreen: 11.4
How to fix
Upgrade to a fixed version: FirebirdSQL firebird 2.1.7. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0523.html
- http://lists.opensuse.org/opensuse-security-announce/2014-12/msg00012.html
- http://tracker.firebirdsql.org/browse/CORE-4630
- http://www.debian.org/security/2014/dsa-3109
- http://www.firebirdsql.org/en/news/security-updates-for-v2-1-and-v2-5-series-66011/
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:172
- https://usn.ubuntu.com/3929-1/
- http://advisories.mageia.org/MGASA-2014-0523.html
- http://lists.opensuse.org/opensuse-security-announce/2014-12/msg00012.html
- http://tracker.firebirdsql.org/browse/CORE-4630
- http://www.debian.org/security/2014/dsa-3109
- http://www.firebirdsql.org/en/news/security-updates-for-v2-1-and-v2-5-series-66011/
Get alerted when CVE-2014-9323 or the next vulnerability affects your stack