What’s Vulnerable › Vulnerabilities
CVE-2014-9428
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-01-02 · updated 2026-06-17
- Weakness: CWE-399
Description
The batadv_frag_merge_packets function in net/batman-adv/fragmentation.c in the B.A.T.M.A.N. implementation in the Linux kernel through 3.18.1 uses an incorrect length field during a calculation of an amount of memory, which allows remote attackers to cause a denial of service (mesh-node system crash) via fragmented packets.
Affected products
- Linux kernel: from 3.13 before 3.14.30; from 3.15 before 3.16.35; from 3.17 before 3.18.4 — fixed in 3.14.30, 3.16.35, 3.18.4
How to fix
Upgrade to a fixed version: Linux kernel 3.14.30, 3.16.35, 3.18.4. Check the vendor advisory for mitigations.
References
- http://bugs.debian.org/774155
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=5b6698b0e4a37053de35cc24ee695b98a7eb712b
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/147864.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/147973.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:058
- http://www.openwall.com/lists/oss-security/2014/12/31/7
- http://www.spinics.net/lists/netdev/msg309425.html
- http://www.ubuntu.com/usn/USN-2515-1
- http://www.ubuntu.com/usn/USN-2516-1
- http://www.ubuntu.com/usn/USN-2517-1
- http://www.ubuntu.com/usn/USN-2518-1
- https://github.com/torvalds/linux/commit/5b6698b0e4a37053de35cc24ee695b98a7eb712b
Get alerted when CVE-2014-9428 or the next vulnerability affects your stack