What’s Vulnerable › Vulnerabilities
CVE-2014-9470
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the loadForm function in Frontend/Modules/Search/Actions/Index.php in Fork CMS before 3.8.4 allows remote attackers to inject arbitrary web script or HTML via the q_widget parameter to en/search.
Affected products
- forkcms/forkcms: before 3.8.4 — fixed in 3.8.4
How to fix
Upgrade to a fixed version: forkcms/forkcms 3.8.4. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2015/Jan/38
- http://www.fork-cms.com/blog/detail/fork-3.8.4-released
- http://www.itas.vn/news/itas-team-found-out-a-cross-site-scripting-vulnerability-in-fork-cms-70.html
- http://www.securityfocus.com/bid/72017
- https://github.com/forkcms/forkcms/commit/4a7814762adf4f56f932d95146c7e4126d872114
- https://github.com/forkcms/forkcms/issues/1018s
- http://seclists.org/fulldisclosure/2015/Jan/38
- http://www.fork-cms.com/blog/detail/fork-3.8.4-released
- http://www.itas.vn/news/itas-team-found-out-a-cross-site-scripting-vulnerability-in-fork-cms-70.html
- http://www.securityfocus.com/bid/72017
- https://github.com/forkcms/forkcms/commit/4a7814762adf4f56f932d95146c7e4126d872114
- https://github.com/forkcms/forkcms/issues/1018s
Get alerted when CVE-2014-9470 or the next vulnerability affects your stack