What’s Vulnerable › Vulnerabilities
CVE-2014-9471
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-01-16 · updated 2026-06-17
Description
The parse_datetime function in GNU coreutils allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted date string, as demonstrated by the "--date=TZ="123"345" @1" string to the touch or date command.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 14.04
- GNU coreutils: before 8.23 — fixed in 8.23
How to fix
Upgrade to a fixed version: GNU coreutils 8.23. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2015-0029.html
- http://debbugs.gnu.org/cgi/bugreport.cgi?bug=16872
- http://secunia.com/advisories/62226
- http://ubuntu.com/usn/usn-2473-1
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:179
- http://www.openwall.com/lists/oss-security/2014/11/25/1
- http://www.openwall.com/lists/oss-security/2014/11/25/4
- http://www.openwall.com/lists/oss-security/2015/01/03/11
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=766147
- https://security.gentoo.org/glsa/201612-22
- http://advisories.mageia.org/MGASA-2015-0029.html
- http://debbugs.gnu.org/cgi/bugreport.cgi?bug=16872
Get alerted when CVE-2014-9471 or the next vulnerability affects your stack