What’s Vulnerable › Vulnerabilities
CVE-2014-9605
- Severity: critical (CVSS 9.4 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-09-04 · updated 2026-06-17
- Weakness: CWE-287
Description
WebUpgrade in Netsweeper before 3.1.10, 4.0.x before 4.0.9, and 4.1.x before 4.1.2 allows remote attackers to bypass authentication and create a system backup tarball, restart the server, or stop the filters on the server via a ' (single quote) character in the login and password parameters to webupgrade/webupgrade.php. NOTE: this was originally reported as an SQL injection vulnerability, but this may be inaccurate.
Affected products
- Netsweeper: from 3.1.0 before 3.1.10; from 4.0.0 before 4.0.9; from 4.1.0 before 4.1.2 — fixed in 3.1.10, 4.0.9, 4.1.2
How to fix
Upgrade to a fixed version: Netsweeper 3.1.10, 4.0.9, 4.1.2. Check the vendor advisory for mitigations.
References
- https://helpdesk.netsweeper.com/docs/3.1/release_notes/netsweeper_releasenotes/3_1_10_0_release_notes/3.1.10_release_notes.htm
- https://helpdesk.netsweeper.com/docs/4.0/release_notes/netsweeper_releasenotes/4_0_9_release_notes/4.0.9_release_notes.htm
- https://helpdesk.netsweeper.com/docs/4.1/release_notes/netsweeper_releasenotes/4_1_release_notes/4_1_2_release_notes/4.1.2_release_notes.htm
- https://www.exploit-db.com/exploits/37928/
- https://helpdesk.netsweeper.com/docs/3.1/release_notes/netsweeper_releasenotes/3_1_10_0_release_notes/3.1.10_release_notes.htm
- https://helpdesk.netsweeper.com/docs/4.0/release_notes/netsweeper_releasenotes/4_0_9_release_notes/4.0.9_release_notes.htm
- https://helpdesk.netsweeper.com/docs/4.1/release_notes/netsweeper_releasenotes/4_1_release_notes/4_1_2_release_notes/4.1.2_release_notes.htm
- https://www.exploit-db.com/exploits/37928/
Get alerted when CVE-2014-9605 or the next vulnerability affects your stack