What’s Vulnerable › Vulnerabilities
CVE-2014-9625
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-24 · updated 2026-06-17
- Weakness: CWE-120
Description
The GetUpdateFile function in misc/update.c in the Updater in VideoLAN VLC media player before 2.1.6 performs an incorrect cast operation from a 64-bit integer to a 32-bit integer, which allows remote attackers to conduct buffer overflow attacks and execute arbitrary code via a crafted update status file, aka an "integer truncation" vulnerability.
Affected products
- VideoLAN VLC: before 2.1.6 — fixed in 2.1.6
How to fix
Upgrade to a fixed version: VideoLAN VLC 2.1.6. Check the vendor advisory for mitigations.
References
- http://openwall.com/lists/oss-security/2015/01/20/5
- https://github.com/videolan/vlc/commit/fbe2837bc80f155c001781041a54c58b5524fc14
- https://www.videolan.org/security/sa1501.html
- http://openwall.com/lists/oss-security/2015/01/20/5
- https://github.com/videolan/vlc/commit/fbe2837bc80f155c001781041a54c58b5524fc14
- https://www.videolan.org/security/sa1501.html
Get alerted when CVE-2014-9625 or the next vulnerability affects your stack