What’s Vulnerable › Vulnerabilities

CVE-2014-9629

Description

Integer overflow in the Encode function in modules/codec/schroedinger.c in VideoLAN VLC media player before 2.1.6 and 2.2.x before 2.2.1 allows remote attackers to conduct buffer overflow attacks and execute arbitrary code via a crafted length value.

Affected products

How to fix

Upgrade to a fixed version: VideoLAN VLC 2.1.6, 2.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-9629 or the next vulnerability affects your stack