What’s Vulnerable › Vulnerabilities
CVE-2014-9644
- Severity: low (CVSS 2.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-03-02 · updated 2026-06-17
- Weakness: CWE-269
Description
The Crypto API in the Linux kernel before 3.18.5 allows local users to load arbitrary kernel modules via a bind system call for an AF_ALG socket with a parenthesized module template expression in the salg_name field, as demonstrated by the vfat(aes) expression, a different vulnerability than CVE-2013-7421.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10
- Debian Linux: 7.0, 8.0
- Linux kernel: before 3.18.5 — fixed in 3.18.5
- Oracle Corporation Oracle Linux: 5, 6, 7
How to fix
Upgrade to a fixed version: Linux kernel 3.18.5. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=4943ba16bbc2db05115707b3ff7b4874e9e3c560
- http://rhn.redhat.com/errata/RHSA-2016-0068.html
- http://www.debian.org/security/2015/dsa-3170
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.5
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:057
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:058
- http://www.openwall.com/lists/oss-security/2015/01/24/4
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
- http://www.securityfocus.com/bid/72320
- http://www.ubuntu.com/usn/USN-2513-1
- http://www.ubuntu.com/usn/USN-2514-1
Get alerted when CVE-2014-9644 or the next vulnerability affects your stack