What’s Vulnerable › Vulnerabilities

CVE-2014-9709

Description

The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.4.40, 5.5.21, 5.6.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-9709 or the next vulnerability affects your stack