What’s Vulnerable › Vulnerabilities
CVE-2014-9756
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-11-19 · updated 2026-06-17
- Weakness: CWE-369
Description
The psf_fwrite function in file_io.c in libsndfile allows attackers to cause a denial of service (divide-by-zero error and application crash) via unspecified vectors related to the headindex variable.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Flexera Software LLC libsndfile: before 1.0.26 — fixed in 1.0.26
- openSUSE Leap: 42.1
- Opensuse: 13.1, 13.2
How to fix
Upgrade to a fixed version: Flexera Software LLC libsndfile 1.0.26. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00077.html
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00145.html
- http://www.openwall.com/lists/oss-security/2014/12/24/3
- http://www.openwall.com/lists/oss-security/2015/11/03/9
- http://www.ubuntu.com/usn/USN-2832-1
- https://github.com/erikd/libsndfile/commit/725c7dbb95bfaf8b4bb7b04820e3a00cceea9ce6
- https://github.com/erikd/libsndfile/issues/92
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00077.html
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00145.html
- http://www.openwall.com/lists/oss-security/2014/12/24/3
- http://www.openwall.com/lists/oss-security/2015/11/03/9
- http://www.ubuntu.com/usn/USN-2832-1
Get alerted when CVE-2014-9756 or the next vulnerability affects your stack