What’s Vulnerable › Vulnerabilities
CVE-2014-9819
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-30 · updated 2026-06-17
- Weakness: CWE-119
Description
Heap-based buffer overflow in ImageMagick allows remote attackers to have unspecified impact via a crafted palm file, a different vulnerability than CVE-2014-9823.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/12/24/1
- http://www.openwall.com/lists/oss-security/2016/06/02/13
- https://anonscm.debian.org/cgit/collab-maint/imagemagick.git/commit/?h=debian-patches/6.8.9.9-4-for-upstream&id=0a89a1ccca6e7ee059b73f5cc924513383e8a330
- https://bugzilla.redhat.com/show_bug.cgi?id=1343475
- http://www.openwall.com/lists/oss-security/2014/12/24/1
- http://www.openwall.com/lists/oss-security/2016/06/02/13
- https://anonscm.debian.org/cgit/collab-maint/imagemagick.git/commit/?h=debian-patches/6.8.9.9-4-for-upstream&id=0a89a1ccca6e7ee059b73f5cc924513383e8a330
- https://bugzilla.redhat.com/show_bug.cgi?id=1343475
Get alerted when CVE-2014-9819 or the next vulnerability affects your stack