What’s Vulnerable › Vulnerabilities
CVE-2014-9828
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-07 · updated 2026-06-17
- Weakness: CWE-284
Description
coders/psd.c in ImageMagick allows remote attackers to have unspecified impact via a crafted psd file.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/06/02/13
- https://anonscm.debian.org/cgit/collab-maint/imagemagick.git/commit/?h=debian-patches/6.8.9.9-4-for-upstream&id=460547be494cc8c039b99b65e64a1fa2eb08ab5c
- https://bugzilla.redhat.com/show_bug.cgi?id=1343484
- http://www.openwall.com/lists/oss-security/2016/06/02/13
- https://anonscm.debian.org/cgit/collab-maint/imagemagick.git/commit/?h=debian-patches/6.8.9.9-4-for-upstream&id=460547be494cc8c039b99b65e64a1fa2eb08ab5c
- https://bugzilla.redhat.com/show_bug.cgi?id=1343484
Get alerted when CVE-2014-9828 or the next vulnerability affects your stack