What’s Vulnerable › Vulnerabilities
CVE-2014-9848
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-20 · updated 2026-06-17
- Weakness: CWE-399
Description
Memory leak in ImageMagick allows remote attackers to cause a denial of service (memory consumption).
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 16.10
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
- openSUSE Leap: 42.2
- Opensuse: 13.2
- Opensuse Project Leap: 42.1
- Opensuse Project Suse Linux Enterprise Desktop: 12.0-sp1, 12.0-sp2
- Opensuse Project Suse Linux Enterprise Server: 12.0-sp1, 12.0-sp2
- Opensuse Project Suse Linux Enterprise Server For Raspberry Pi: 12.0-sp2
- Opensuse Project Suse Linux Enterprise Software Development Kit: 12.0-sp1, 12.0-sp2
- Opensuse Project Suse Linux Enterprise Workstation Extension: 12.0-sp1, 12.0-sp2
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00093.html
- http://lists.opensuse.org/opensuse-security-announce/2017-01/msg00006.html
- http://www.openwall.com/lists/oss-security/2016/06/02/13
- http://www.ubuntu.com/usn/USN-3131-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1343507
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00093.html
Get alerted when CVE-2014-9848 or the next vulnerability affects your stack