What’s Vulnerable › Vulnerabilities
CVE-2014-9853
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-17 · updated 2026-06-17
- Weakness: CWE-399
Description
Memory leak in coders/rle.c in ImageMagick allows remote attackers to cause a denial of service (memory consumption) via a crafted rle file.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 16.10
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
- Novell Leap: 42.2
- openSUSE Leap: 42.1
- Opensuse: 13.2
- Opensuse Project Suse Linux Enterprise Software Development Kit: 11.0-sp4
- SUSE Linux Enterprise Debuginfo: 11-sp4
- SUSE Linux Enterprise Server 15 SP1: 12-sp1
- SUSE Linux Enterprise Server: 11-sp4, 12-sp1
- SUSE Linux Enterprise Software Development Kit: 12-sp1
- SUSE Linux Enterprise Workstation Extension: 12-sp1
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00037.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00028.html
- http://www.openwall.com/lists/oss-security/2016/06/02/13
- http://www.ubuntu.com/usn/USN-3131-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1343513
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00000.html
Get alerted when CVE-2014-9853 or the next vulnerability affects your stack