What’s Vulnerable › Vulnerabilities
CVE-2014-9854
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-17 · updated 2026-06-17
- Weakness: CWE-399
Description
coders/tiff.c in ImageMagick allows remote attackers to cause a denial of service (application crash) via vectors related to the "identification of image."
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 16.10
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
- openSUSE Leap: 42.1
- Opensuse: 13.2
- SUSE Linux Enterprise Server: 11-sp4
- SUSE Linux Enterprise Software Development Kit: 11-sp4
- SUSE Linux Enterprise: 12
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://git.imagemagick.org/repos/ImageMagick/commit/7fb9b7e095a65b4528d0180e26574f2bc7cd0e8b
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00018.html
- http://www.openwall.com/lists/oss-security/2016/06/02/13
- http://www.ubuntu.com/usn/USN-3131-1
- https://anonscm.debian.org/cgit/collab-maint/imagemagick.git/commit/?h=debian-patches/6.8.9.9-4-for-upstream&id=5ee6f49297c8137cae527429e0267462c14ec3ed
- https://bugzilla.redhat.com/show_bug.cgi?id=1343514
- http://git.imagemagick.org/repos/ImageMagick/commit/7fb9b7e095a65b4528d0180e26574f2bc7cd0e8b
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00009.html
Get alerted when CVE-2014-9854 or the next vulnerability affects your stack