What’s Vulnerable › Vulnerabilities
CVE-2014-9938
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-03-20 · updated 2026-06-17
- Weakness: CWE-116
Description
contrib/completion/git-prompt.sh in Git before 1.9.3 does not sanitize branch names in the PS1 variable, allowing a malicious repository to cause code execution.
Affected products
- git: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: git 1.9.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2017:2004
- https://github.com/git/git/commit/8976500cbbb13270398d3b3e07a17b8cc7bff43f
- https://github.com/njhartwell/pw3nage
- https://access.redhat.com/errata/RHSA-2017:2004
- https://github.com/git/git/commit/8976500cbbb13270398d3b3e07a17b8cc7bff43f
- https://github.com/njhartwell/pw3nage
Get alerted when CVE-2014-9938 or the next vulnerability affects your stack