What’s Vulnerable › Vulnerabilities
CVE-2015-0235
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 94.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-01-28 · updated 2026-06-17
- Weakness: CWE-787
Description
Heap-based buffer overflow in the __nss_hostname_digits_dots function in glibc 2.2, and other 2.x versions before 2.18, allows context-dependent attackers to execute arbitrary code via vectors related to the (1) gethostbyname or (2) gethostbyname2 function, aka "GHOST."
Affected products
- macOS: before 10.11.1 — fixed in 10.11.1
- Debian Linux: 7.0, 8.0
- GNU C Library (glibc): from 2.0 before 2.18 — fixed in 2.18
- IBM PureApplication System: 1.0.0.0, 1.1.0.0, 2.0.0.0
- IBM Security Access Manager for Enterprise Single Sign-On: 8.2
- Oracle Communications Application Session Controller: before 3.7.1 — fixed in 3.7.1
- Oracle Communications Eagle Application Processor: 16.0
- Oracle Communications Eagle Lnp Application Processor: 10.0
- Oracle Communications Lsms: 13.1
- Oracle Corporation Communications Policy Management: 9.7.3, 9.9.1, 10.4.1, 11.5, 12.1.1
- Oracle Corporation Communications Session Border Controller: before 7.2.0; 7.2.0, 8.0.0 — fixed in 7.2.0
- Oracle Communications User Data Repository: from 10.0.0 through 10.0.1
- Oracle Corporation Communications WebRTC Session Controller: 7.0, 7.1, 7.2
- Oracle Exalogic Infrastructure: 1.0, 2.0
- Oracle Corporation Oracle Linux: 5, 7-0
- Oracle Corporation VM VirtualBox: before 5.1.24 — fixed in 5.1.24
- PHP: from 5.4.0 before 5.4.38; from 5.5.0 before 5.5.22; from 5.6.0 before 5.6.6 — fixed in 5.4.38, 5.5.22, 5.6.6
- RedHat Virtualization: 6.0
How to fix
Upgrade to a fixed version: macOS 10.11.1; GNU C Library (glibc) 2.18; Oracle Communications Application Session Controller 3.7.1; Oracle Corporation Communications Session Border Controller 7.2.0; Oracle Corporation VM VirtualBox 5.1.24; PHP 5.4.38, 5.5.22, 5.6.6. Check the vendor advisory for mitigations.
References
- http://blogs.sophos.com/2015/01/29/sophos-products-and-the-ghost-vulnerability-affecting-linux/
- http://linux.oracle.com/errata/ELSA-2015-0090.html
- http://linux.oracle.com/errata/ELSA-2015-0092.html
- http://lists.apple.com/archives/security-announce/2015/Jun/msg00002.html
- http://lists.apple.com/archives/security-announce/2015/Oct/msg00005.html
- http://lists.apple.com/archives/security-announce/2015/Sep/msg00008.html
- http://marc.info/?l=bugtraq&m=142296726407499&w=2
- http://marc.info/?l=bugtraq&m=142721102728110&w=2
- http://marc.info/?l=bugtraq&m=142722450701342&w=2
- http://marc.info/?l=bugtraq&m=142781412222323&w=2
- http://marc.info/?l=bugtraq&m=143145428124857&w=2
- http://packetstormsecurity.com/files/130171/Exim-ESMTP-GHOST-Denial-Of-Service.html
Get alerted when CVE-2015-0235 or the next vulnerability affects your stack