What’s Vulnerable › Vulnerabilities
CVE-2015-0239
- Severity: medium (CVSS 4.4 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-03-02 · updated 2026-06-17
- Weakness: CWE-269
Description
The em_sysenter function in arch/x86/kvm/emulate.c in the Linux kernel before 3.18.5, when the guest OS lacks SYSENTER MSR initialization, allows guest OS users to gain guest OS privileges or cause a denial of service (guest OS crash) by triggering use of a 16-bit code segment for emulation of a SYSENTER instruction.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10
- Debian Linux: 7.0, 8.0
- Linux kernel: before 3.18.5 — fixed in 3.18.5
- Oracle Corporation Oracle Linux: 5, 7
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: Linux kernel 3.18.5. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=f3747379accba8e95d70cec0eae0582c8c182050
- http://permalink.gmane.org/gmane.linux.kernel.commits.head/502245
- http://rhn.redhat.com/errata/RHSA-2015-1272.html
- http://www.debian.org/security/2015/dsa-3170
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.5
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:058
- http://www.openwall.com/lists/oss-security/2015/01/27/6
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
- http://www.securityfocus.com/bid/72842
- http://www.ubuntu.com/usn/USN-2513-1
- http://www.ubuntu.com/usn/USN-2514-1
Get alerted when CVE-2015-0239 or the next vulnerability affects your stack