What’s Vulnerable › Vulnerabilities

CVE-2015-0241

Description

The to_char function in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allows remote authenticated users to cause a denial of service (crash) or possibly execute arbitrary code via a (1) large number of digits when processing a numeric formatting template, which triggers a buffer over-read, or (2) crafted timestamp formatting template, which triggers a buffer overflow.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 9.0.19, 9.1.15, 9.2.10, 9.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-0241 or the next vulnerability affects your stack